<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"/>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=195-0&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=195-0&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=195-0&cb=5', false, [], true, false, true, false);</script><style id="litespeed-optm-css-rules">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel=&#39;stylesheet&#39;" href="https://sciencefiction.com/wp-content/litespeed/cssjs/bac35.css?3f269"/><script id="litespeed-css-async-lib">!function(a){"use strict";var b=function(b,c,d){function e(a){return h.body?a():void setTimeout(function(){e(a)})}function f(){i.addEventListener&&i.removeEventListener("load",f),i.media=d||"all"}var g,h=a.document,i=h.createElement("link");if(c)g=c;else{var j=(h.body||h.getElementsByTagName("head")[0]).childNodes;g=j[j.length-1]}var k=h.styleSheets;i.rel="stylesheet",i.href=b,i.media="only x",e(function(){g.parentNode.insertBefore(i,c?g:g.nextSibling)});var l=function(a){for(var b=i.href,c=k.length;c--;)if(k[c].href===b)return a();setTimeout(function(){l(a)})};return i.addEventListener&&i.addEventListener("load",f),i.onloadcssdefined=l,l(f),i};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this);!function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(b){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script><meta http-equiv="x-dns-prefetch-control" content="on"/><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"/><link rel="profile" href="http://gmpg.org/xfn/11"/><link rel="pingback" href="https://sciencefiction.com/xmlrpc.php"/><title>Check Out The New Trailer And Poster For Marvel&#39;s &#39;The Eternals&#39; - ScienceFiction.com</title><meta name="robots" content="index, follow"/><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"/><meta property="og:locale" content="en_US"/><meta property="og:type" content="article"/><meta property="og:title" content="Check Out The New Trailer And Poster For Marvel&#39;s &#39;The Eternals&#39; - ScienceFiction.com"/><meta property="og:description" content="After the strangeness of 2020 and its impact on movies and the entertainment world in general, the release slate for the second half of this year is, to put it mildly, jam-packed.  Several films that were meant to make their cinematic debut last year were bumped back – in some cases several times – and in 2021, movie-goers will finally get to see many of these delayed offerings. It makes for a very busy time, and for franchises, it means that many releases are coming to audiences much closer together on the calendar than they normally would.  The perfect example of this is with the ever-expanding Marvel Cinematic Universe; between the scheduled US openings of ‘Black Widow’ on July 9 of this year and ‘Black Panther: Wakanda Forever’ on July 8, 2022, there are a whopping 7 MCU films coming to the big screens, averaging out to a new Marvel movie less than every other month.  (And that doesn’t even count the 4 MCU TV series coming to Disney+ during that time as well!) Smack-dab in the middle of all this is the scheduled release of Marvel’s ‘The Eternals,’ coming to US theaters on November 5th.  Today, the powers-that-be at […]"/><meta property="og:url" content="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"/><meta property="og:site_name" content="ScienceFiction.com"/><meta property="article:publisher" content="https://facebook.com/ScienceFiction"/><meta property="article:author" content="tonyschaab"/><meta property="article:published_time" content="2021-05-24T14:50:15+00:00"/><meta property="article:modified_time" content="2021-05-24T15:02:32+00:00"/><meta property="og:image" content="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1.jpg"/><meta property="og:image:width" content="725"/><meta property="og:image:height" content="500"/><meta name="twitter:card" content="summary_large_image"/><meta name="twitter:creator" content="@tonyschaab"/><meta name="twitter:site" content="@ScienceFiction"/> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://sciencefiction.com/#website","url":"https://sciencefiction.com/","name":"ScienceFiction.com","description":"Science Fiction (sci-fi) news, books, tv, movies, comic books, video games and more...","potentialAction":[{"@type":"SearchAction","target":"https://sciencefiction.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/#primaryimage","inLanguage":"en-US","url":"https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1.jpg","width":725,"height":500},{"@type":"WebPage","@id":"https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/#webpage","url":"https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/","name":"Check Out The New Trailer And Poster For Marvel's 'The Eternals' - ScienceFiction.com","isPartOf":{"@id":"https://sciencefiction.com/#website"},"primaryImageOfPage":{"@id":"https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/#primaryimage"},"datePublished":"2021-05-24T14:50:15+00:00","dateModified":"2021-05-24T15:02:32+00:00","author":{"@id":"https://sciencefiction.com/#/schema/person/bd394ae81d252e29937f6c47b6bb6417"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"]}]},{"@type":["Person"],"@id":"https://sciencefiction.com/#/schema/person/bd394ae81d252e29937f6c47b6bb6417","name":"Tony Schaab - Senior Editor","image":{"@type":"ImageObject","@id":"https://sciencefiction.com/#personlogo","inLanguage":"en-US","url":"https://sciencefiction.com/wp-content/litespeed/avatar/978017b6c409a9f403165745c3e3e883.jpg","caption":"Tony Schaab - Senior Editor"},"description":"Tony Schaab is a freelance pop-culture writer in addition to being an award-winning author and best-selling review critic, with his book series \u201cThe G.O.R.E. Score: A Review Guide to All Things Zombie\u201d being an 8-time #1 best-seller (Amazon Kindle, Pop Culture chart, 2012-2017). Working as a DJ and Master of Ceremonies since 1999, he has performed MC/DJ work for the NFL, MTV, NBA, Wizard World Comic Con, PGA, IndyCar, and countless private events. Tony lives in Indianapolis with his wife, 10-year-old daughter, 2-year-old son, and two rambunctious rescue dogs. Learn more about Tony at TonySchaab.com and chat him up on Twitter @TonySchaab.","sameAs":["tonyschaab","tonyschaab","https://twitter.com/tonyschaab"]}]}</script> <link rel="dns-prefetch" href="//fonts.googleapis.com"/><link rel="dns-prefetch" href="//s.w.org"/><link rel="alternate" type="application/rss+xml" title="ScienceFiction.com » Feed" href="https://sciencefiction.com/feed/"/><link rel="alternate" type="application/rss+xml" title="ScienceFiction.com » Comments Feed" href="https://sciencefiction.com/comments/feed/"/><link rel="alternate" type="application/rss+xml" title="ScienceFiction.com » Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’ Comments Feed" href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/feed/"/><link rel="preconnect" href="https://www.zergnet.com"/><link rel="preload" href="https://sciencefiction.com/wp-content/themes/broden/fonts/fontawesome-webfont.woff2?v=4.5.0" as="font" crossorigin="anonymous"/><link rel="https://api.w.org/" href="https://sciencefiction.com/wp-json/"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sciencefiction.com/xmlrpc.php?rsd"/><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sciencefiction.com/wp-includes/wlwmanifest.xml"/><meta name="generator" content="WordPress 5.4.6"/><link rel="shortlink" href="https://sciencefiction.com/?p=355616"/><link rel="alternate" type="application/json+oembed" href="https://sciencefiction.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F"/><link rel="alternate" type="text/xml+oembed" href="https://sciencefiction.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;format=xml"/> <script data-cfasync="false" src="data:text/javascript;base64,d2luZG93LmEyYV9jb25maWc9d2luZG93LmEyYV9jb25maWd8fHt9O2EyYV9jb25maWcuY2FsbGJhY2tzPVtdO2EyYV9jb25maWcub3ZlcmxheXM9W107YTJhX2NvbmZpZy50ZW1wbGF0ZXM9e307KGZ1bmN0aW9uKGQscyxhLGIpe2E9ZC5jcmVhdGVFbGVtZW50KHMpO2I9ZC5nZXRFbGVtZW50c0J5VGFnTmFtZShzKVswXTthLmFzeW5jPTE7YS5zcmM9Imh0dHBzOi8vc3RhdGljLmFkZHRvYW55LmNvbS9tZW51L3BhZ2UuanMiO2IucGFyZW50Tm9kZS5pbnNlcnRCZWZvcmUoYSxiKTt9KShkb2N1bWVudCwic2NyaXB0Iik7" defer=""></script> <style type="text/css">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</style> <script src="data:text/javascript;base64,d2luZG93LmdhPXdpbmRvdy5nYXx8ZnVuY3Rpb24oKXsoZ2EucT1nYS5xfHxbXSkucHVzaChhcmd1bWVudHMpO307Z2EubD0rbmV3IERhdGU7" defer=""></script> <script>// You're always allowing cookies. No additional script is needed.</script> <script src="data:text/javascript;base64,Z2EoJ2NyZWF0ZScsJ1VBLTIwMzc5NTgzLTEnLHsiY29va2llTmFtZSI6ImNhb3NMb2NhbEdhIiwiY29va2llRG9tYWluIjoic2NpZW5jZWZpY3Rpb24uY29tIiwiY29va2llRXhwaXJlcyI6MCwiY29va2llRmxhZ3MiOiJzYW1lc2l0ZT1ub25lO3NlY3VyZSJ9KTtnYSgnc2VuZCcsJ3BhZ2V2aWV3Jyk7" defer=""></script> <script type="text/javascript">var ezouid = "1";</script><base href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"><script type='text/javascript'>
var ezoTemplate = 'old_site_noads';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 247944;
var ezdomain = 'sciencefiction.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":247944,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"8d19a3c6-cd7a-46b2-66ba-8939fd25891b","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":75504,"response_time_orig":4,"serverid":"34.237.223.225:21257","state":"VA","t_epoch":1623857914,"template_id":120,"time_on_site_visit":0,"url":"https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/","user_id":0,"word_count":876,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_247944=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["8d19a3c6-cd7a-46b2-66ba-8939fd25891b", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head><body class="post-template-default single single-post postid-355616 single-format-standard"><div class="wrapper"><div class="sidebar-navigation"><div class="sidebar-scroll scrollbar-macosx"><div class="close-sidebar-button">
<a href="#" class="close-btn"><span>Close Sidebar</span><i class="fa fa-close"></i></a></div><div class="sidebar-navigation-logo"></div><nav class="navbar"><ul id="menu-main-navigation" class="mobile-menu"><li id="menu-item-13866" class="firstnavlink menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13866"><a href="http://sciencefiction.com/">Home</a></li><li id="menu-item-252343" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252343"><a href="https://sciencefiction.com/movies/">Movies</a></li><li id="menu-item-252342" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252342"><a href="https://sciencefiction.com/tv-streaming/">TV</a></li><li id="menu-item-252344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252344"><a href="https://sciencefiction.com/comic-books/">Comic Books</a></li><li id="menu-item-252345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252345"><a href="https://sciencefiction.com/video-games/">Video Games</a></li><li id="menu-item-252346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252346"><a href="https://sciencefiction.com/books/">Books</a></li><li id="menu-item-252347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252347"><a href="https://sciencefiction.com/science-and-tech/">Science &amp; Tech</a></li><li id="menu-item-25162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25162"><a href="https://sciencefiction.com/about/">About</a></li><li id="menu-item-25163" class="lastnavlink menu-item menu-item-type-post_type menu-item-object-page menu-item-25163"><a href="https://sciencefiction.com/contact/">Contact</a></li></ul></nav><div class="sidebar-navigation-social"></div><div class="sidebar-navigation-copyright"></div></div></div><div class="sidebar-overlay close-btn"></div><div class="blog-inwrap"><header class="style-1"><div class="mobile-topbar visible-sm visible-xs"><div class="container"><div class="sidebar-button"><a href="#"><span></span></a></div><div class="search-button search-for-mobile"><div class="mobile-search"><form method="get" class="search-form" role="search" action="https://sciencefiction.com/">
<input type="search" class="form-control" value="" name="s" placeholder="SEARCH..."/>
<button type="submit" class="btn btn-default">Search</button></form>					<a title="Search" class="search-toggle"><i class="fa fa-search"></i></a></div></div></div></div><div class="header-main"><div class="container"><div class="social-button">
<a class="social-toggle"><i class="fa fa-share-alt"></i></a><div class="social-links"><ul><li><a class="facebook" href="https://facebook.com/ScienceFiction" target="_blank" title="Facebook"><i class="fa fa-facebook"></i></a></li><li><a class="twitter" href="https://twitter.com/sciencefiction" target="_blank" title="Twitter"><i class="fa fa-twitter"></i></a></li></ul></div></div><div class="brand-logo">
<a href="https://sciencefiction.com/">
<img src="https://sciencefiction.com/wp-content/uploads/2019/04/science_fiction_logo-2019.png" alt="ScienceFiction.com" class="normal-logo visible-lg visible-md"/>
<img src="https://sciencefiction.com/wp-content/uploads/2019/04/science_fiction_logo-2019.png" alt="ScienceFiction.com" class="mobile-logo visible-sm visible-xs"/>
<img src="https://sciencefiction.com/wp-content/uploads/2019/04/science_fiction_logo-2019.png" alt="ScienceFiction.com" class="logo-fixed"/>
</a></div><div class="search-button"><div class="dropdown"><form method="get" class="search-form" role="search" action="https://sciencefiction.com/">
<input type="search" class="form-control" value="" name="s" placeholder="SEARCH..."/>
<button type="submit" class="btn btn-default">Search</button></form>					<a title="Search" class="search-toggle" data-toggle="dropdown" aria-expanded="false"><i class="fa fa-search"></i></a></div></div></div></div><div class="header-bottom visible-lg visible-md"><div class="container"><nav class="main-menu"><ul id="menu-main-navigation-1" class="menu"><li class="firstnavlink menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13866"><a href="http://sciencefiction.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252343"><a href="https://sciencefiction.com/movies/">Movies</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252342"><a href="https://sciencefiction.com/tv-streaming/">TV</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252344"><a href="https://sciencefiction.com/comic-books/">Comic Books</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252345"><a href="https://sciencefiction.com/video-games/">Video Games</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252346"><a href="https://sciencefiction.com/books/">Books</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252347"><a href="https://sciencefiction.com/science-and-tech/">Science &amp; Tech</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25162"><a href="https://sciencefiction.com/about/">About</a></li><li class="lastnavlink menu-item menu-item-type-post_type menu-item-object-page menu-item-25163"><a href="https://sciencefiction.com/contact/">Contact</a></li></ul></nav></div></div></header><section class="main"><center><section class="blog-main"><div class="container"><div class="row"><div class="col-md-8 col-sm-12 col-xs-12 blog-posts"><article id="post-355616" class="page-post post post-355616 type-post status-publish format-standard has-post-thumbnail hentry category-marvel category-movies tag-details tag-discussion tag-marvel-cinematic-universe tag-observations tag-plot tag-poster tag-synopsis tag-the-eternals tag-trailer" itemscope="itemscope" itemtype="http://schema.org/Article"><div class="post-header"><div class="post-cat"><ul><li class="cat"><a href="https://sciencefiction.com/marvel/" rel="category tag">Marvel</a></li><li class="cat"><a href="https://sciencefiction.com/movies/" rel="category tag">Movies</a></li></ul></div><div class="post-title"><h1 itemprop="name">Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’</h1></div><div class="post-meta"><div class="post-comment"><i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="355616 https://sciencefiction.com/?p=355616">Leave a comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> Posted May 24th, 2021 by <a href="https://sciencefiction.com/author/tony-schaab/" title="Posts by Tony Schaab - Senior Editor" rel="author">Tony Schaab - Senior Editor</a></div></div></div><div class="post-inwrap"><div class="post-content post-entry"><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/" data-a2a-title="Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_skype" href="https://www.addtoany.com/add_to/skype?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Skype" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_like addtoany_special_service" data-layout="button" data-href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"></a><a class="a2a_button_twitter_tweet addtoany_special_service" data-url="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/" data-text="Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><p><a href="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1.jpg"><img class="aligncenter size-full wp-image-355617" src="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1.jpg" alt="" width="725" height="500" srcset="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1.jpg 725w, https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1-200x138.jpg 200w" sizes="(max-width: 725px) 100vw, 725px"/></a></p><p>After the strangeness of 2020 and its impact on movies and the entertainment world in general, the release slate for the second half of this year is, to put it mildly, jam-packed.  Several films that were meant to make their cinematic debut last year were bumped back – in some cases several times – and in 2021, movie-goers will finally get to see many of these delayed offerings.</p><p>It makes for a very busy time, and for franchises, it means that many releases are coming to audiences much closer together on the calendar than they normally would.  The perfect example of this is with the ever-expanding Marvel Cinematic Universe; between the scheduled US openings of ‘Black Widow’ on July 9 of this year and ‘Black Panther: Wakanda Forever’ on July 8, 2022, there are a whopping 7 MCU films coming to the big screens, averaging out to a new Marvel movie less than every other month.  (And that doesn’t even count the 4 MCU TV series coming to Disney+ during that time as well!)</p><p>Smack-dab in the middle of all this is the scheduled release of Marvel’s ‘The Eternals,’ coming to US theaters on November 5th.  Today, the powers-that-be at Marvel have graced us with a new teaser trailer, showing us some of the first actual footage from the film.  This coincides with the newest poster for the film, both of which tease the arrival of the titular aliens on Earth and a bit about the world-shaking issue that has caused them to finally make their presence known after millenia of staying in the shadows.</p><p>From Marvel and IMDB, here is the short-and-sweet synopsis and summary of the film:</p><blockquote><p>“Throughout the years we have never interfered, until now.” Watch the brand new teaser trailer for Marvel Studios’ “Eternals” and experience it in theaters this November.</p><p>Following the events of ‘Avengers: Endgame,’ an unexpected tragedy forces the Eternals, ancient aliens who have been living on Earth in secret for thousands of years, out of the shadows to reunite against mankind’s most ancient enemy, the Deviants.</p></blockquote><p>Call me crazy, but Thanos seems like a fairly large threat, so these super-powered aliens better have a darned good reason for staying hidden and on the sidelines during that whole conflict, as shown to audiences in the aforementioned ‘Avengers: Endgame.’  I’m confident it will be addressed somewhere in the film, likely early on, lest Marvel dare incur the wrath of the vengeful and confused fanboys (like myself, of course).</p><p>Anyhow, check out the new teaser trailer and full poster below!</p><p style="text-align: center;"><iframe title="YouTube video player" src="https://www.youtube.com/embed/0WVDKZJkGlY" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p><p><a href="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Movie-Poster.jpg"><img class="aligncenter size-full wp-image-355618" src="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Movie-Poster.jpg" alt="" width="864" height="1280" srcset="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Movie-Poster.jpg 864w, https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Movie-Poster-200x296.jpg 200w, https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Movie-Poster-750x1111.jpg 750w, https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Movie-Poster-768x1138.jpg 768w" sizes="(max-width: 864px) 100vw, 864px"/></a></p><p><strong>‘The Eternals’ is scheduled to premiere in US theaters on November 5, 2021.</strong></p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/" data-a2a-title="Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_skype" href="https://www.addtoany.com/add_to/skype?linkurl=https%3A%2F%2Fsciencefiction.com%2F2021%2F05%2F24%2Fcheck-out-the-new-trailer-and-poster-for-marvels-the-eternals%2F&amp;linkname=Check%20Out%20The%20New%20Trailer%20And%20Poster%20For%20Marvel%E2%80%99s%20%E2%80%98The%20Eternals%E2%80%99" title="Skype" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_like addtoany_special_service" data-layout="button" data-href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"></a><a class="a2a_button_twitter_tweet addtoany_special_service" data-url="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/" data-text="Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div></div><div class="post-tags"><span class="single-tag-list-title">Tags:</span><ul><li><a href="https://sciencefiction.com/tag/details/" rel="tag">details</a></li><li><a href="https://sciencefiction.com/tag/discussion/" rel="tag">discussion</a></li><li><a href="https://sciencefiction.com/tag/marvel-cinematic-universe/" rel="tag">Marvel cinematic universe</a></li><li><a href="https://sciencefiction.com/tag/observations/" rel="tag">observations</a></li><li><a href="https://sciencefiction.com/tag/plot/" rel="tag">plot</a></li><li><a href="https://sciencefiction.com/tag/poster/" rel="tag">Poster</a></li><li><a href="https://sciencefiction.com/tag/synopsis/" rel="tag">Synopsis</a></li><li><a href="https://sciencefiction.com/tag/the-eternals/" rel="tag">The Eternals</a></li><li><a href="https://sciencefiction.com/tag/trailer/" rel="tag">Trailer</a></li></ul></div><div class="post-author"><div class="author-image">
<img alt="" src="https://sciencefiction.com/wp-content/litespeed/avatar/17378c79df024a3dfbc72150956f6a2f.jpg" srcset="https://sciencefiction.com/wp-content/litespeed/avatar/b93bdca9d0e7a38a3e386e83ade83492.jpg 2x" class="avatar avatar-80 photo" height="80" width="80"/></div><div class="author-info"><h3 class="author-name">
Tony Schaab - Senior Editor</h3><p>Tony Schaab is a freelance pop-culture writer in addition to being an award-winning author and best-selling review critic, with his book series “The G.O.R.E. Score: A Review Guide to All Things Zombie” being an 8-time #1 best-seller (Amazon Kindle, Pop Culture chart, 2012-2017). Working as a DJ and Master of Ceremonies since 1999, he has performed MC/DJ work for the NFL, MTV, NBA, Wizard World Comic Con, PGA, IndyCar, and countless private events. Tony lives in Indianapolis with his wife, 10-year-old daughter, 2-year-old son, and two rambunctious rescue dogs. Learn more about Tony at TonySchaab.com and chat him up on Twitter @TonySchaab.</p><ul><li><a target="_blank" href="http://facebook.com/tonyschaab"><i class="fa fa-facebook"></i></a></li><li><a target="_blank" href="http://twitter.com/tonyschaab"><i class="fa fa-twitter"></i></a></li><li><a target="_blank" href="http://instagram.com/tonyschaab"><i class="fa fa-instagram"></i></a></li></ul></div></div><div style="clear:both;"></div><nav class="post-directions"><div class="row"><div class="col-md-6 col-sm-6 col-xs-12 previous-article">
<i class="fa fa-angle-left"></i><div class="post-directions-inwrap">
<span></span>
<a href="https://sciencefiction.com/2021/05/13/throwback-thursday-kolchak-the-night-stalker/">Throwback Thursday: ‘Kolchak: The Night Stalker’ (1974)</a></div></div><div class="col-md-6 col-sm-6 col-xs-12 next-article"></div></div></nav><aside class="related-posts"><div class="related-posts-inwrap"><div class="row"><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-189051 post type-post status-publish format-standard hentry category-comic-books category-marvel category-movies category-x-men tag-bryan-singer tag-x-men-days-of-future-past-the-rogue-cut" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2015/07/02/building-character-check-new-preview-x-men-days-future-past-rogue-cut-intro-bryan-singer/">
<img src="https://sciencefiction.com/wp-content/themes/broden/images/default-post-image.jpg" alt="Building Character: Check Out New Preview of ‘X-Men: Days of Future Past – The Rogue Cut’ With Intro by Bryan Singer"/>
</a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2015/07/02/building-character-check-new-preview-x-men-days-future-past-rogue-cut-intro-bryan-singer/" title="Building Character: Check Out New Preview of ‘X-Men: Days of Future Past – The Rogue Cut’ With Intro by Bryan Singer">Building Character: Check Out New Preview of ‘X-Men: Days of Future Past – The Rogue Cut’ With Intro by Bryan Singer</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2015/07/02/building-character-check-new-preview-x-men-days-future-past-rogue-cut-intro-bryan-singer/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="189051 http://sciencefiction.com/?p=189051">1 Comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> July 2, 2015</div></div></div></article><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-42877 post type-post status-publish format-standard hentry category-comic-books category-marvel category-x-men tag-comic-book-review tag-greg-land tag-justin-ponsor tag-kieron-gillen tag-marvel tag-uncanny-x-men-5 tag-uncanny-x-men-5-review" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2012/01/22/comic-book-review-uncanny-x-men-5/">
<img src="https://sciencefiction.com/wp-content/themes/broden/images/default-post-image.jpg" alt="Comic Book Review: ‘Uncanny X-Men’ #5"/>
</a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2012/01/22/comic-book-review-uncanny-x-men-5/" title="Comic Book Review: ‘Uncanny X-Men’ #5">Comic Book Review: ‘Uncanny X-Men’ #5</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2012/01/22/comic-book-review-uncanny-x-men-5/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="42877 http://sciencefiction.com/?p=42877">9 Comments</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> January 22, 2012</div></div></div></article><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-336820 post type-post status-publish format-standard has-post-thumbnail hentry category-marvel category-movies tag-infinity-saga tag-iron-man tag-kevin-feige tag-marvel tag-marvel-cinematic-universe tag-marvel-studios tag-mcu tag-nick-fury tag-robert-downy-jr tag-samuel-l-jackson tag-saturn-awards" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2019/09/16/kevin-feige-shares-original-iron-man-post-credits-scene-which-references-radioactive-bug-bites-and-mutants/"><img width="770" height="560" src="https://sciencefiction.com/wp-content/uploads/2019/05/Captain-Marvel-Stan-Lee-Tribute-770x560.jpg" class="attachment-broden-post-type-thumb size-broden-post-type-thumb wp-post-image" alt="" itemprop="image"/></a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2019/09/16/kevin-feige-shares-original-iron-man-post-credits-scene-which-references-radioactive-bug-bites-and-mutants/" title="Kevin Feige Shares Original ‘Iron Man’ Post-Credits Scene Which References “Radioactive Bug Bites” And “Mutants”">Kevin Feige Shares Original ‘Iron Man’ Post-Credits Scene Which References “Radioactive Bug Bites” And “Mutants”</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2019/09/16/kevin-feige-shares-original-iron-man-post-credits-scene-which-references-radioactive-bug-bites-and-mutants/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="336820 https://sciencefiction.com/?p=336820">Leave a comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> September 16, 2019</div></div></div></article><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-69761 post type-post status-publish format-standard hentry category-movies tag-blackwell tag-cassandra-clare tag-guy-ritchie tag-harald-zwart tag-i-am-number-four tag-insane-clown-posse tag-jamie-campbell-bower tag-jemima-west tag-kevin-durand tag-kurrgan tag-lily-collins tag-pangborn tag-reel-steal tag-robert-maillet tag-sherlock-holmes tag-the-mortal-instruments tag-the-oddities" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2012/07/07/new-actors-join-lily-collins-in-the-mortal-instruments/">
<img src="https://sciencefiction.com/wp-content/themes/broden/images/default-post-image.jpg" alt="New Actors Join Lily Collins In ‘The Mortal Instruments’"/>
</a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2012/07/07/new-actors-join-lily-collins-in-the-mortal-instruments/" title="New Actors Join Lily Collins In ‘The Mortal Instruments’">New Actors Join Lily Collins In ‘The Mortal Instruments’</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2012/07/07/new-actors-join-lily-collins-in-the-mortal-instruments/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="69761 http://sciencefiction.com/?p=69761">Leave a comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> July 7, 2012</div></div></div></article></div></div></aside><div id="disqus_thread"></div></div></article></div><div class="col-md-4 col-sm-12 col-xs-12 sidebar"><div class="sidebar-inwrap"><aside id="mc4wp_form_widget-4" class="widget widget_mc4wp_form_widget"><div class="widget-title"><h4>Newsletter Signup</h4></div><script src="data:text/javascript;base64,KGZ1bmN0aW9uKCl7d2luZG93Lm1jNHdwPXdpbmRvdy5tYzR3cHx8e2xpc3RlbmVyczpbXSxmb3Jtczp7b246ZnVuY3Rpb24oZXZ0LGNiKXt3aW5kb3cubWM0d3AubGlzdGVuZXJzLnB1c2goe2V2ZW50OmV2dCxjYWxsYmFjazpjYn0pO319fX0pKCk7" defer=""></script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-252323 mc4wp-form-theme mc4wp-form-theme-light" method="post" data-id="252323" data-name="Site Subscribe"><div class="mc4wp-form-fields"><p>
<label>Email address: </label>
<input type="email" name="EMAIL" placeholder="Your email address" required=""/></p><p>
<input type="submit" value="Sign up"/></p></div><label style="display: none !important;">Leave this field empty if you&#39;re human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"/></label><input type="hidden" name="_mc4wp_timestamp" value="1621868685"/><input type="hidden" name="_mc4wp_form_id" value="252323"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"/><div class="mc4wp-response"></div></form></aside><aside id="broden_latest_posts_widget-4" class="widget latest-posts-widget"><div class="widget-title"><h4>Latest Articles</h4></div><div class="widget-inwrap"><ul><li class="post-355616 post type-post status-publish format-standard has-post-thumbnail hentry category-marvel category-movies tag-details tag-discussion tag-marvel-cinematic-universe tag-observations tag-plot tag-poster tag-synopsis tag-the-eternals tag-trailer"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2021/05/Eternals-Featured-1-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/" title="Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’" rel="bookmark">Check Out The New Trailer And Poster For Marvel’s ‘The Eternals’</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2021/05/24/check-out-the-new-trailer-and-poster-for-marvels-the-eternals/"><i class="fa fa-clock-o"></i> May 24, 2021</a></div></div></div></li><li class="post-355607 post type-post status-publish format-standard has-post-thumbnail hentry category-throwback category-tv-streaming tag-analysis tag-darren-mcgavin tag-kolchak tag-observations tag-recap tag-retro tag-review tag-the-night-stalker tag-trivia"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2021/05/13/throwback-thursday-kolchak-the-night-stalker/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2021/05/Kolchak_The_Night_Stalker1974-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2021/05/13/throwback-thursday-kolchak-the-night-stalker/" title="Throwback Thursday: ‘Kolchak: The Night Stalker’ (1974)" rel="bookmark">Throwback Thursday: ‘Kolchak: The Night Stalker’ (1974)</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2021/05/13/throwback-thursday-kolchak-the-night-stalker/"><i class="fa fa-clock-o"></i> May 13, 2021</a></div></div></div></li><li class="post-355591 post type-post status-publish format-standard has-post-thumbnail hentry category-netflix category-toys-games category-tv-streaming tag-cartoon tag-cast tag-details tag-he-man tag-images tag-kevin-smith tag-masters-of-the-universe tag-masters-of-the-universe-revelation tag-new-series tag-plot tag-synopsis"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2021/05/13/10-new-images-from-netflixs-upcoming-masters-of-the-universe-miniseries/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2021/05/Masters-of-the-Universe-Revelation-1-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2021/05/13/10-new-images-from-netflixs-upcoming-masters-of-the-universe-miniseries/" title="10 New Images From Netflix’s Upcoming ‘Masters Of The Universe’ Miniseries" rel="bookmark">10 New Images From Netflix’s Upcoming ‘Masters Of The Universe’ Miniseries</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2021/05/13/10-new-images-from-netflixs-upcoming-masters-of-the-universe-miniseries/"><i class="fa fa-clock-o"></i> May 13, 2021</a></div></div></div></li><li class="post-355582 post type-post status-publish format-standard has-post-thumbnail hentry category-boom-studios category-comic-books category-horror tag-basilisk tag-boom-studios-2 tag-cullen-bunn tag-new-horror tag-series"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2021/05/10/new-horror-series-basilisk-coming-from-comic-book-stalwarts-cullen-bunn-and-jonas-scharf/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2021/05/Basilisk-Featured-150x150.png" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2021/05/10/new-horror-series-basilisk-coming-from-comic-book-stalwarts-cullen-bunn-and-jonas-scharf/" title="New Horror Series ‘Basilisk’ Coming From Comic Book Stalwarts Cullen Bunn And Jonas Scharf" rel="bookmark">New Horror Series ‘Basilisk’ Coming From Comic Book Stalwarts Cullen Bunn And Jonas Scharf</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2021/05/10/new-horror-series-basilisk-coming-from-comic-book-stalwarts-cullen-bunn-and-jonas-scharf/"><i class="fa fa-clock-o"></i> May 10, 2021</a></div></div></div></li></ul></div></aside><aside id="broden_popular_posts_widget-4" class="widget most-popular-widget"><div class="widget-title"><h4>Most Popular Articles</h4></div><div class="widget-inwrap"><ul><li class="post-257878 post type-post status-publish format-standard has-post-thumbnail hentry category-comic-books category-marvel category-tv-streaming tag-the-defenders tag-tv-review"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2017/08/23/tv-defenders-review-episodes-3-4/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2017/08/DEFENDERS-ready-for-action-HEADER-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2017/08/23/tv-defenders-review-episodes-3-4/" title="TV REVIEW: ‘The Defenders’ – Episodes 3 &amp; 4" rel="bookmark">TV REVIEW: ‘The Defenders’ – Episodes 3 &amp; 4</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2017/08/23/tv-defenders-review-episodes-3-4/"><i class="fa fa-clock-o"></i> August 23, 2017</a></div></div></div></li><li class="post-52559 post type-post status-publish format-standard has-post-thumbnail hentry category-comic-books category-featured category-other"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2012/03/17/top-10-green-super-heroes/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2012/03/Green-Lantern-1024x575-640x359-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2012/03/17/top-10-green-super-heroes/" title="Top 10 Green Superheroes" rel="bookmark">Top 10 Green Superheroes</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2012/03/17/top-10-green-super-heroes/"><i class="fa fa-clock-o"></i> March 17, 2012</a></div></div></div></li><li class="post-277016 post type-post status-publish format-standard has-post-thumbnail hentry category-movies category-science-and-tech tag-jurassic-world-3"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2018/02/22/circle-life-jurassic-world-3-eyeing-2021-release-date-complete-trilogy/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2018/02/jurassic-world-blu-ray-t-rex-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2018/02/22/circle-life-jurassic-world-3-eyeing-2021-release-date-complete-trilogy/" title="Circle Of Life: ‘Jurassic World 3’ Eyeing 2021 Release Date To Complete Trilogy" rel="bookmark">Circle Of Life: ‘Jurassic World 3’ Eyeing 2021 Release Date To Complete Trilogy</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2018/02/22/circle-life-jurassic-world-3-eyeing-2021-release-date-complete-trilogy/"><i class="fa fa-clock-o"></i> February 22, 2018</a></div></div></div></li><li class="post-350453 post type-post status-publish format-standard has-post-thumbnail hentry category-events category-featured category-movies tag-amblin-entertainment tag-richard-donner tag-steven-spielberg tag-the-goonies tag-warner-brothers"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2020/02/10/oregon-is-hosting-a-four-day-event-to-celebrate-the-35th-anniversary-of-the-goonies/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2020/02/10/oregon-is-hosting-a-four-day-event-to-celebrate-the-35th-anniversary-of-the-goonies/" title="Oregon Is Hosting A Four-Day Event To Celebrate The 35th Anniversary Of ‘The Goonies’" rel="bookmark">Oregon Is Hosting A Four-Day Event To Celebrate The 35th Anniversary Of ‘The Goonies’</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2020/02/10/oregon-is-hosting-a-four-day-event-to-celebrate-the-35th-anniversary-of-the-goonies/"><i class="fa fa-clock-o"></i> February 10, 2020</a></div></div></div></li><li class="post-105228 post type-post status-publish format-standard has-post-thumbnail hentry category-comic-books category-dc-comics category-image-comics category-marvel tag-dc-comics tag-lbgt tag-marvel tag-transgender"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2013/04/15/top-ten-transgender-comic-book-characters/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2013/04/alysia-yeoh-batgirl-150x150.png" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt=""/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2013/04/15/top-ten-transgender-comic-book-characters/" title="Top Ten Transgender Comic Book Characters" rel="bookmark">Top Ten Transgender Comic Book Characters</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2013/04/15/top-ten-transgender-comic-book-characters/"><i class="fa fa-clock-o"></i> April 15, 2013</a></div></div></div></li><li class="post-308647 post type-post status-publish format-standard has-post-thumbnail hentry category-books category-featured category-movies category-tv-streaming tag-kingkiller-chronicle tag-lin-manuel-miranda tag-lionsgate tag-patrick-rothfuss tag-sam-raimi tag-showtime"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2018/12/01/raimi-kingkiller-chronicle/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="Sam Raimi"/>								</a></figure><div class="post-inwrap"><div class="post-title"><h2 class="entry-title"><a href="https://sciencefiction.com/2018/12/01/raimi-kingkiller-chronicle/" title="EXCLUSIVE: Sam Raimi No Longer Attached To Direct ‘Kingkiller Chronicle’ Movie" rel="bookmark">EXCLUSIVE: Sam Raimi No Longer Attached To Direct ‘Kingkiller Chronicle’ Movie</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2018/12/01/raimi-kingkiller-chronicle/"><i class="fa fa-clock-o"></i> December 1, 2018</a></div></div></div></li></ul></div></aside></div></div></div></div></section></center></section><footer><div class="copyright"><p><span class="copy1"> Copyright ©2021 Science Fiction.</span>
<span class="copy-2">All Rights Reserved</span> | <a href="https://sciencefiction.com/privacy-policy">Privacy Policy</a> | <a href="https://sciencefiction.com/do-not-sell-my-information">Do Not Sell My Information</a><br/><br/>
<span>Website Design and <a href="https://quichost.com/" alt="HTTP3/QUIC Hosting" target="_blank" rel="noopener">HTTP3/QUIC Hosting</a> by <a href="https://quichost.com/" alt="HTTP3/QUIC Hosting" target="_blank" rel="noopener">QUICHOST.COM</a></span></p></div><div class="back-to-top"><a href="#"><i class="fa fa-angle-double-up"></i></a></div></footer></div></div> <script type="text/javascript" src="data:text/javascript;base64,dmFyIF91c2Vyd2F5X2NvbmZpZz17YWNjb3VudDonQzBvSHdNcGRjSyd9Ow==" defer=""></script> <script type="text/javascript" defer="" data-deferred="1" data-type="lazy" data-src="https://cdn.userway.org/widget.js"></script><script src="data:text/javascript;base64,KGZ1bmN0aW9uKCl7ZnVuY3Rpb24gbWF5YmVQcmVmaXhVcmxGaWVsZCgpe2lmKHRoaXMudmFsdWUudHJpbSgpIT09JycmJnRoaXMudmFsdWUuaW5kZXhPZignaHR0cCcpIT09MCl7dGhpcy52YWx1ZT0iaHR0cDovLyIrdGhpcy52YWx1ZTt9fQp2YXIgdXJsRmllbGRzPWRvY3VtZW50LnF1ZXJ5U2VsZWN0b3JBbGwoJy5tYzR3cC1mb3JtIGlucHV0W3R5cGU9InVybCJdJyk7aWYodXJsRmllbGRzKXtmb3IodmFyIGo9MDtqPHVybEZpZWxkcy5sZW5ndGg7aisrKXt1cmxGaWVsZHNbal0uYWRkRXZlbnRMaXN0ZW5lcignYmx1cicsbWF5YmVQcmVmaXhVcmxGaWVsZCk7fX19KSgpOw==" defer=""></script> <script type="text/javascript" src="data:text/javascript;base64,dmFyIGNvdW50VmFycz17ImRpc3F1c1Nob3J0bmFtZSI6InNjaWVuY2VmaWN0aW9uY29tIn07dmFyIGVtYmVkVmFycz17ImRpc3F1c0NvbmZpZyI6eyJpbnRlZ3JhdGlvbiI6IndvcmRwcmVzcyAzLjAuMTYifSwiZGlzcXVzSWRlbnRpZmllciI6IjM1NTYxNiBodHRwczpcL1wvc2NpZW5jZWZpY3Rpb24uY29tXC8/cD0zNTU2MTYiLCJkaXNxdXNTaG9ydG5hbWUiOiJzY2llbmNlZmljdGlvbmNvbSIsImRpc3F1c1RpdGxlIjoiQ2hlY2sgT3V0IFRoZSBOZXcgVHJhaWxlciBBbmQgUG9zdGVyIEZvciBNYXJ2ZWxcdTIwMTlzIFx1MjAxOFRoZSBFdGVybmFsc1x1MjAxOSIsImRpc3F1c1VybCI6Imh0dHBzOlwvXC9zY2llbmNlZmljdGlvbi5jb21cLzIwMjFcLzA1XC8yNFwvY2hlY2stb3V0LXRoZS1uZXctdHJhaWxlci1hbmQtcG9zdGVyLWZvci1tYXJ2ZWxzLXRoZS1ldGVybmFsc1wvIiwicG9zdElkIjoiMzU1NjE2In07dmFyIGRjbEN1c3RvbVZhcnM9eyJkY2xfcHJvZ3Jlc3NfdGV4dCI6IkxvYWRpbmcuLi4ifTs=" defer=""></script> <script type="text/javascript" src="data:text/javascript;base64,dmFyIHRoZW1lYWpheD17ImFqYXh1cmwiOiJodHRwczpcL1wvc2NpZW5jZWZpY3Rpb24uY29tXC93cC1hZG1pblwvYWRtaW4tYWpheC5waHAifTs=" defer=""></script> <script type="text/javascript" id="flying-scripts" src="data:text/javascript;base64,Y29uc3QgbG9hZFNjcmlwdHNUaW1lcj1zZXRUaW1lb3V0KGxvYWRTY3JpcHRzLDcqMTAwMCk7Y29uc3QgdXNlckludGVyYWN0aW9uRXZlbnRzPVsibW91c2VvdmVyIiwia2V5ZG93biIsInRvdWNobW92ZSIsInRvdWNoc3RhcnQiXTt1c2VySW50ZXJhY3Rpb25FdmVudHMuZm9yRWFjaChmdW5jdGlvbihldmVudCl7d2luZG93LmFkZEV2ZW50TGlzdGVuZXIoZXZlbnQsdHJpZ2dlclNjcmlwdExvYWRlcix7cGFzc2l2ZTohMH0pfSk7ZnVuY3Rpb24gdHJpZ2dlclNjcmlwdExvYWRlcigpe2xvYWRTY3JpcHRzKCk7Y2xlYXJUaW1lb3V0KGxvYWRTY3JpcHRzVGltZXIpO3VzZXJJbnRlcmFjdGlvbkV2ZW50cy5mb3JFYWNoKGZ1bmN0aW9uKGV2ZW50KXt3aW5kb3cucmVtb3ZlRXZlbnRMaXN0ZW5lcihldmVudCx0cmlnZ2VyU2NyaXB0TG9hZGVyLHtwYXNzaXZlOiEwfSl9KX0KZnVuY3Rpb24gbG9hZFNjcmlwdHMoKXtkb2N1bWVudC5xdWVyeVNlbGVjdG9yQWxsKCJzY3JpcHRbZGF0YS10eXBlPSdsYXp5J10iKS5mb3JFYWNoKGZ1bmN0aW9uKGVsZW0pe2VsZW0uc2V0QXR0cmlidXRlKCJzcmMiLGVsZW0uZ2V0QXR0cmlidXRlKCJkYXRhLXNyYyIpKX0pfQ==" defer=""></script> <script data-optimized="1" src="https://sciencefiction.com/wp-content/litespeed/cssjs/fc75c.js?b379c" defer=""></script>

<script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('/detroitchicago/edmonton.webp', '/detroitchicago/edmonton.webp?a=a&cb=0&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('/porpoiseant/jellyfish.webp', '/porpoiseant/jellyfish.webp?a=a&cb=0&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="sciencefiction_com",_audins_did=247944;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=195-0");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.sciencefiction_com,DomainId.247944" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script>
<script>__ez.queue.addFile('/tardisrocinante/vitals.js', '/tardisrocinante/vitals.js?gcb=0&cb=3', false, ['/detroitchicago/minneapolis.js'], true, false, true, false);</script><script type="text/javascript" onload="__ezcl.handle(true);" async src="/utilcave_com/inc/ezcl.webp?cb=4"></script></body></html><!-- Page optimized by LiteSpeed Cache @2021-05-24 15:04:45 --><!-- Page generated by LiteSpeed Cache 3.6.2 on 2021-05-24 11:04:45 -->