<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><style id="litespeed-optm-css-rules">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</style><link rel="preload" data-asynced="1" data-optimized="2" as="style" onload="this.onload=null;this.rel='stylesheet'" href="https://sciencefiction.com/wp-content/litespeed/cssjs/46544.css?57f69" /><script data-optimized="1" src="https://sciencefiction.com/wp-content/litespeed/cssjs/77b07.js?e4e20" defer></script><script id="litespeed-css-async-lib">!function(a){"use strict";var b=function(b,c,d){function e(a){return h.body?a():void setTimeout(function(){e(a)})}function f(){i.addEventListener&&i.removeEventListener("load",f),i.media=d||"all"}var g,h=a.document,i=h.createElement("link");if(c)g=c;else{var j=(h.body||h.getElementsByTagName("head")[0]).childNodes;g=j[j.length-1]}var k=h.styleSheets;i.rel="stylesheet",i.href=b,i.media="only x",e(function(){g.parentNode.insertBefore(i,c?g:g.nextSibling)});var l=function(a){for(var b=i.href,c=k.length;c--;)if(k[c].href===b)return a();setTimeout(function(){l(a)})};return i.addEventListener&&i.addEventListener("load",f),i.onloadcssdefined=l,l(f),i};"undefined"!=typeof exports?exports.loadCSS=b:a.loadCSS=b}("undefined"!=typeof global?global:this);!function(a){if(a.loadCSS){var b=loadCSS.relpreload={};if(b.support=function(){try{return a.document.createElement("link").relList.supports("preload")}catch(b){return!1}},b.poly=function(){for(var b=a.document.getElementsByTagName("link"),c=0;c<b.length;c++){var d=b[c];"preload"===d.rel&&"style"===d.getAttribute("as")&&(a.loadCSS(d.href,d,d.getAttribute("media")),d.rel=null)}},!b.support()){b.poly();var c=a.setInterval(b.poly,300);a.addEventListener&&a.addEventListener("load",function(){b.poly(),a.clearInterval(c)}),a.attachEvent&&a.attachEvent("onload",function(){a.clearInterval(c)})}}}(this);</script><meta http-equiv="x-dns-prefetch-control" content="on"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://sciencefiction.com/xmlrpc.php"><title>The First Teaser Trailer For Robert Kirkman&#039;s &#039;Invincible&#039; Has Arrived - ScienceFiction.com</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The First Teaser Trailer For Robert Kirkman&#039;s &#039;Invincible&#039; Has Arrived - ScienceFiction.com" /><meta property="og:description" content="Robert Kirkman is known to many pop-culture fans as the man who created &#8216;The Walking Dead&#8217; (technically co-created with artist and longtime collaborator Tony Moore), the Image Comics comic-book series that spawned a hugely successful TV show that is still running into its eleventh season on AMC &#8211; and which, in turn, has spawned several other series spin-offs as well. Before &#8216;The Walking Dead,&#8217; however, Kirkman and artist Cory Walker co-created another title for Image: the son-of-a-famous-superhero-gets-powers-of-his-own tale &#8216;Invincible,&#8217; and it was a massive hit.  Praised as a more realistic take on a superhero story, the series ran for 144 issues from 2003 to 2018.  Once set to be adapted into a feature film, &#8216;Invincible&#8217; finds life as an adult-oriented animated series on Amazon&#8217;s Prime Video, coming to audiences next year in what&#8217;s reported to be an hour-long each, 8-episode first season. The voice cast for the new series is impressively long, and reads as a &#8220;who&#8217;s who&#8221; of genre stalwarts mixed with several mainstays of &#8216;The Walking Dead&#8217; TV series.  Ranging from recurring roles to one-off appearances, the announced cast includes Steven Yeun as Mark Grayson/Invincible, J. K. Simmons as Nolan Grayson/Omni-Man, Sandra Oh as Debbie Grayson, Mark Hamill [&hellip;]" /><meta property="og:url" content="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" /><meta property="og:site_name" content="ScienceFiction.com" /><meta property="article:publisher" content="https://facebook.com/ScienceFiction" /><meta property="article:author" content="tonyschaab" /><meta property="article:published_time" content="2020-10-12T19:39:25+00:00" /><meta property="og:image" content="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-2.png" /><meta property="og:image:width" content="1324" /><meta property="og:image:height" content="956" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@tonyschaab" /><meta name="twitter:site" content="@ScienceFiction" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://sciencefiction.com/#website","url":"https://sciencefiction.com/","name":"ScienceFiction.com","description":"Science Fiction (sci-fi) news, books, tv, movies, comic books, video games and more...","potentialAction":[{"@type":"SearchAction","target":"https://sciencefiction.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/#primaryimage","inLanguage":"en-US","url":"https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-2.png","width":1324,"height":956,"caption":"from Prime Video teaser trailer"},{"@type":"WebPage","@id":"https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/#webpage","url":"https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/","name":"The First Teaser Trailer For Robert Kirkman's 'Invincible' Has Arrived - ScienceFiction.com","isPartOf":{"@id":"https://sciencefiction.com/#website"},"primaryImageOfPage":{"@id":"https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/#primaryimage"},"datePublished":"2020-10-12T19:39:25+00:00","dateModified":"2020-10-12T19:39:25+00:00","author":{"@id":"https://sciencefiction.com/#/schema/person/bd394ae81d252e29937f6c47b6bb6417"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/"]}]},{"@type":["Person"],"@id":"https://sciencefiction.com/#/schema/person/bd394ae81d252e29937f6c47b6bb6417","name":"Tony Schaab - Senior Editor","image":{"@type":"ImageObject","@id":"https://sciencefiction.com/#personlogo","inLanguage":"en-US","url":"https://sciencefiction.com/wp-content/litespeed/avatar/978017b6c409a9f403165745c3e3e883.jpg","caption":"Tony Schaab - Senior Editor"},"description":"Tony Schaab is a freelance pop-culture writer in addition to being an award-winning author and best-selling review critic, with his book series \u201cThe G.O.R.E. Score: A Review Guide to All Things Zombie\u201d being an 8-time #1 best-seller (Amazon Kindle, Pop Culture chart, 2012-2017). Working as a DJ and Master of Ceremonies since 1999, he has performed MC/DJ work for the NFL, MTV, NBA, Wizard World Comic Con, PGA, IndyCar, and countless private events. Tony lives in Indianapolis with his wife, 10-year-old daughter, 2-year-old son, and two rambunctious rescue dogs. Learn more about Tony at TonySchaab.com and chat him up on Twitter @TonySchaab.","sameAs":["tonyschaab","tonyschaab","https://twitter.com/tonyschaab"]}]}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="ScienceFiction.com &raquo; Feed" href="https://sciencefiction.com/feed/" /><link rel="alternate" type="application/rss+xml" title="ScienceFiction.com &raquo; Comments Feed" href="https://sciencefiction.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="ScienceFiction.com &raquo; The First Teaser Trailer For Robert Kirkman&#8217;s &#8216;Invincible&#8217; Has Arrived Comments Feed" href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/feed/" /><link rel='preconnect' href='https://www.zergnet.com'  /><link rel='preload' href='https://sciencefiction.com/wp-content/themes/broden/fonts/fontawesome-webfont.woff2?v=4.5.0' as='font'  crossorigin="anonymous"/><link rel='https://api.w.org/' href='https://sciencefiction.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sciencefiction.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sciencefiction.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.4.2" /><link rel='shortlink' href='https://sciencefiction.com/?p=355269' /><link rel="alternate" type="application/json+oembed" href="https://sciencefiction.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F" /><link rel="alternate" type="text/xml+oembed" href="https://sciencefiction.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&#038;format=xml" /> <script src="data:text/javascript;base64, d2luZG93LmEyYV9jb25maWc9d2luZG93LmEyYV9jb25maWd8fHt9O2EyYV9jb25maWcuY2FsbGJhY2tzPVtdO2EyYV9jb25maWcub3ZlcmxheXM9W107YTJhX2NvbmZpZy50ZW1wbGF0ZXM9e307KGZ1bmN0aW9uKGQscyxhLGIpe2E9ZC5jcmVhdGVFbGVtZW50KHMpO2I9ZC5nZXRFbGVtZW50c0J5VGFnTmFtZShzKVswXTthLmFzeW5jPTE7YS5zcmM9Imh0dHBzOi8vc3RhdGljLmFkZHRvYW55LmNvbS9tZW51L3BhZ2UuanMiO2IucGFyZW50Tm9kZS5pbnNlcnRCZWZvcmUoYSxiKTt9KShkb2N1bWVudCwic2NyaXB0Iik7" defer data-cfasync="false"></script> <style type="text/css">body{font-family:Montserrat}h1,h2,h3,h4,h5,h6{font-family:Montserrat}.post .post-cat ul li a,.post .post-meta .post-comment a,.post .post-meta .post-date,.error-404.not-found h1{font-family:Rajdhani}p{font-family:}header.style-3 .header-main{background:url(https://sciencefiction.com/wp-content/themes/broden/images/header-image.jpg)}header .header-main .brand-logo a img{max-height:px}header .header-main .brand-logo{padding-top:20px;padding-bottom:20px}header .header-main .social-button,header .search-button,header.style-3 .header-main .social-button,header.style-3 .search-button{margin-top:px}header .header-bottom .main-menu>ul li a,.sidebar-navigation .sidebar-scroll .navbar ul li a,.sidebar-navigation .sidebar-scroll .navbar ul li.menu-item-has-children span,.sidebar-navigation .sidebar-scroll .navbar ul li ul li a,.sidebar-navigation .sidebar-scroll .navbar ul li.menu-item-has-children.active{color:!important}header .header-bottom .main-menu ul li>a:hover,header .header-bottom .main-menu ul li:hover>a,header .header-bottom .main-menu ul li>ul li a:hover,header .header-bottom .main-menu ul li>ul li:hover>a{background-color:;color:}header .header-bottom .main-menu ul li>ul,header .header-bottom .main-menu ul li.mega-menu .mega-menu-wrapper,header .header-bottom .main-menu ul li.menu-item-has-children .mega-menu-wrapper,header .header-bottom .main-menu ul li .simple-sub{border-color:}header .social-button a,header .search-button a{color:}header .social-button a:hover,header .header-main .social-button a.social-toggle.active,header .header-bottom.sticky .social-button a.social-toggle.active,header.style-2 .header-bottom .social-button a.social-toggle.active,header .search-button a:hover,header .search-button .dropdown.open a,header .search-button .mobile-search.open a{background-color:;color:}.post .post-cat ul li a{background-color:;color:}.post .post-title h2 a{color:}.post .post-title h2 a:hover{background-color:;color:}.blog-feautured .post .post-inwrap .post-title h2 a:hover{color:}.post .post-content p,.post-post-entry p{color:}.post .post-content p a,.post-post-entry p a{background-color:}.post-comments .comment-list li cite a:hover{background-color:}.post-comments .comment-list li .reply-button a:hover{background-color:}.post-comments .comment-respond form .btn:hover{background-color:}.theme-category-articles .slick-prev:hover:before,.theme-category-articles .slick-next:hover:before{background-color:}.blog-feautured .slick-prev:hover:before,.blog-feautured .slick-next:hover:before{background-color:}.back-to-top a{background-color:;background-color:}.back-to-top a:hover{background-color:}.preloader .lines .line{background-color:}.blog-feautured .featured-style-1:before,.blog-feautured .featured-style-2:before,.blog-feautured .featured-style-3:before,.blog-feautured .featured-style-4:before{background-color:}.widget{background-color:}.widget .widget-title{background-color:}.widget .widget-title h4{color:}.theme-category-articles{background-color:}.blog-feautured .featured-style-1,.blog-feautured .featured-style-2,.blog-feautured .featured-style-4{padding-top:0;padding-bottom:50px}.woocommerce #respond input#submit.alt,.woocommerce a.button.alt,.woocommerce button.button.alt,.woocommerce input.button.alt,.woocommerce .edit-account .button,.woocommerce input[name=login],.woocommerce .return-to-shop a,.woocommerce .lost_reset_password .button{background-color:!important;color:!important}.woocommerce #respond input#submit.alt:hover,.woocommerce a.button.alt:hover,.woocommerce button.button.alt:hover,.woocommerce input.button.alt:hover,.woocommerce .edit-account .button:hover,.woocommerce input[name=login]:hover,.woocommerce .return-to-shop a:hover,.woocommerce .lost_reset_password .button:hover{background-color:!important;color:!important}.woocommerce span.onsale{background-color:!important}.woocommerce ul.products li.product .price{color:!important}.woocommerce ul.products li.product .button{background-color:;border:2px solid;color:}.woocommerce ul.products li.product .button:hover{background-color:;border:2px solid;color:}</style> <script src="data:text/javascript;base64, d2luZG93LmdhPXdpbmRvdy5nYXx8ZnVuY3Rpb24oKXsoZ2EucT1nYS5xfHxbXSkucHVzaChhcmd1bWVudHMpO307Z2EubD0rbmV3IERhdGU7" defer></script> <script ></script> <script src="data:text/javascript;base64, Z2EoJ2NyZWF0ZScsJ1VBLTIwMzc5NTgzLTEnLHsiY29va2llTmFtZSI6ImNhb3NMb2NhbEdhIiwiY29va2llRG9tYWluIjoic2NpZW5jZWZpY3Rpb24uY29tIiwiY29va2llRXhwaXJlcyI6MCwiY29va2llRmxhZ3MiOiJzYW1lc2l0ZT1ub25lO3NlY3VyZSJ9KTtnYSgnc2VuZCcsJ3BhZ2V2aWV3Jyk7" defer></script> </head><body class="post-template-default single single-post postid-355269 single-format-standard"><div class="wrapper"><div class="sidebar-navigation"><div class="sidebar-scroll scrollbar-macosx"><div class="close-sidebar-button">
<a href="#" class="close-btn"><span>Close Sidebar</span><i class="fa fa-close"></i></a></div><div class="sidebar-navigation-logo"></div><nav class="navbar"><ul id="menu-main-navigation" class="mobile-menu"><li id="menu-item-13866" class="firstnavlink menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13866"><a href="https://sciencefiction.com/">Home</a></li><li id="menu-item-252343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252343"><a href="https://sciencefiction.com/movies/">Movies</a></li><li id="menu-item-252342" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252342"><a href="https://sciencefiction.com/tv-streaming/">TV</a></li><li id="menu-item-252344" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252344"><a href="https://sciencefiction.com/comic-books/">Comic Books</a></li><li id="menu-item-252345" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252345"><a href="https://sciencefiction.com/video-games/">Video Games</a></li><li id="menu-item-252346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252346"><a href="https://sciencefiction.com/books/">Books</a></li><li id="menu-item-252347" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252347"><a href="https://sciencefiction.com/science-and-tech/">Science &#038; Tech</a></li><li id="menu-item-25162" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25162"><a href="https://sciencefiction.com/about/">About</a></li><li id="menu-item-25163" class="lastnavlink menu-item menu-item-type-post_type menu-item-object-page menu-item-25163"><a href="https://sciencefiction.com/contact/">Contact</a></li></ul></nav><div class="sidebar-navigation-social"></div><div class="sidebar-navigation-copyright"></div></div></div><div class="sidebar-overlay close-btn"></div><div class="blog-inwrap"><header class="style-1"><div class="mobile-topbar visible-sm visible-xs"><div class="container"><div class="sidebar-button"><a href="#"><span></span></a></div><div class="search-button search-for-mobile"><div class="mobile-search"><form method="get" class="search-form" role="search" action="https://sciencefiction.com/">
<input type="search" class="form-control" value="" name="s" placeholder="SEARCH...">
<button type="submit" class="btn btn-default">Search</button></form>					<a title="Search" class="search-toggle"><i class="fa fa-search"></i></a></div></div></div></div><div class="header-main"><div class="container"><div class="social-button">
<a class="social-toggle"><i class="fa fa-share-alt"></i></a><div class="social-links"><ul><li><a class="facebook" href="https://facebook.com/ScienceFiction" target="_blank" title="Facebook"><i class="fa fa-facebook"></i></a></li><li><a class="twitter" href="https://twitter.com/sciencefiction" target="_blank" title="Twitter"><i class="fa fa-twitter"></i></a></li></ul></div></div><div class="brand-logo">
<a href="https://sciencefiction.com/">
<img src="https://sciencefiction.com/wp-content/uploads/2019/04/science_fiction_logo-2019.png" alt="ScienceFiction.com" class="normal-logo visible-lg visible-md">
<img src="https://sciencefiction.com/wp-content/uploads/2019/04/science_fiction_logo-2019.png" alt="ScienceFiction.com" class="mobile-logo visible-sm visible-xs">
<img src="https://sciencefiction.com/wp-content/uploads/2019/04/science_fiction_logo-2019.png" alt="ScienceFiction.com" class="logo-fixed">
</a></div><div class="search-button"><div class="dropdown"><form method="get" class="search-form" role="search" action="https://sciencefiction.com/">
<input type="search" class="form-control" value="" name="s" placeholder="SEARCH...">
<button type="submit" class="btn btn-default">Search</button></form>					<a title="Search" class="search-toggle" data-toggle="dropdown" aria-expanded="false"><i class="fa fa-search"></i></a></div></div></div></div><div class="header-bottom visible-lg visible-md"><div class="container"><nav class="main-menu"><ul id="menu-main-navigation-1" class="menu"><li class="firstnavlink menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-13866"><a href="https://sciencefiction.com/">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252343"><a href="https://sciencefiction.com/movies/">Movies</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252342"><a href="https://sciencefiction.com/tv-streaming/">TV</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-252344"><a href="https://sciencefiction.com/comic-books/">Comic Books</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252345"><a href="https://sciencefiction.com/video-games/">Video Games</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252346"><a href="https://sciencefiction.com/books/">Books</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252347"><a href="https://sciencefiction.com/science-and-tech/">Science &#038; Tech</a><div class="mega-menu-wrapper no-children"></div></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25162"><a href="https://sciencefiction.com/about/">About</a></li><li class="lastnavlink menu-item menu-item-type-post_type menu-item-object-page menu-item-25163"><a href="https://sciencefiction.com/contact/">Contact</a></li></ul></nav></div></div></header><section class="main"><center><section class="blog-main"><div class="container"><div class="row"><div class="col-md-8 col-sm-12 col-xs-12 blog-posts"><article id="post-355269" class="page-post post post-355269 type-post status-publish format-standard has-post-thumbnail hentry category-amazon-prime category-comic-books category-image-comics category-tv-streaming tag-amazon tag-cartoon tag-image-comics tag-invincible tag-prime-video tag-robert-kirkman tag-seth-rogen tag-the-walking-dead tag-tv-series" itemscope="itemscope" itemtype="http://schema.org/Article"><div class="post-header"><div class="post-cat"><ul><li class="cat"><a href="https://sciencefiction.com/tv-streaming/streaming-service/amazon-prime/" rel="category tag">Amazon Prime</a></li><li class="cat"><a href="https://sciencefiction.com/comic-books/" rel="category tag">Comic Books</a></li><li class="cat"><a href="https://sciencefiction.com/comic-books/image-comics/" rel="category tag">Image Comics</a></li><li class="cat"><a href="https://sciencefiction.com/tv-streaming/" rel="category tag">TV/Streaming Media</a></li></ul></div><div class="post-title"><h1 itemprop="name">The First Teaser Trailer For Robert Kirkman&#8217;s &#8216;Invincible&#8217; Has Arrived</h1></div><div class="post-meta"><div class="post-comment"><i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="355269 https://sciencefiction.com/?p=355269">Leave a comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> Posted October 12th, 2020 by <a href="https://sciencefiction.com/author/tony-schaab/" title="Posts by Tony Schaab - Senior Editor" rel="author">Tony Schaab - Senior Editor</a></div></div></div><div class="post-inwrap"><div class="post-content post-entry"><div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" data-a2a-title="The First Teaser Trailer For Robert Kirkman’s ‘Invincible’ Has Arrived"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_skype" href="https://www.addtoany.com/add_to/skype?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Skype" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_like addtoany_special_service" data-layout="button" data-href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/"></a><a class="a2a_button_twitter_tweet addtoany_special_service" data-url="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" data-text="The First Teaser Trailer For Robert Kirkman’s ‘Invincible’ Has Arrived"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><figure id="attachment_355270" aria-describedby="caption-attachment-355270" style="width: 1919px" class="wp-caption aligncenter"><a href="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo.png"><img class="size-full wp-image-355270" src="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo.png" alt="" width="1919" height="858" srcset="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo.png 1919w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo-200x89.png 200w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo-750x335.png 750w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo-768x343.png 768w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-Logo-1536x687.png 1536w" sizes="(max-width: 1919px) 100vw, 1919px" /></a><figcaption id="caption-attachment-355270" class="wp-caption-text">from Prime Video teaser trailer</figcaption></figure><p>Robert Kirkman is known to many pop-culture fans as the man who created &#8216;The Walking Dead&#8217; (technically co-created with artist and longtime collaborator Tony Moore), the Image Comics comic-book series that spawned a hugely successful TV show that is still running into its eleventh season on AMC &#8211; and which, in turn, has spawned several other series spin-offs as well.</p><p>Before &#8216;The Walking Dead,&#8217; however, Kirkman and artist Cory Walker co-created another title for Image: the son-of-a-famous-superhero-gets-powers-of-his-own tale &#8216;Invincible,&#8217; and it was a massive hit.  Praised as a more realistic take on a superhero story, the series ran for 144 issues from 2003 to 2018.  Once set to be adapted into a feature film, &#8216;Invincible&#8217; finds life as an adult-oriented animated series on Amazon&#8217;s Prime Video, coming to audiences next year in what&#8217;s reported to be an hour-long each, 8-episode first season.</p><figure id="attachment_355272" aria-describedby="caption-attachment-355272" style="width: 1542px" class="wp-caption aligncenter"><a href="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1.png"><img class="size-full wp-image-355272" src="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1.png" alt="" width="1542" height="942" srcset="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1.png 1542w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1-200x122.png 200w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1-750x458.png 750w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1-768x469.png 768w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-1-1536x938.png 1536w" sizes="(max-width: 1542px) 100vw, 1542px" /></a><figcaption id="caption-attachment-355272" class="wp-caption-text">from Prime Video teaser trailer</figcaption></figure><p>The voice cast for the new series is impressively long, and reads as a &#8220;who&#8217;s who&#8221; of genre stalwarts mixed with several mainstays of &#8216;The Walking Dead&#8217; TV series.  Ranging from recurring roles to one-off appearances, the announced cast includes Steven Yeun as Mark Grayson/Invincible, J. K. Simmons as Nolan Grayson/Omni-Man, Sandra Oh as Debbie Grayson, Mark Hamill as Art Rosebaum, Seth Rogen as Allen the Alien, Gillian Jacobs as Samantha Eve Wilkins/Atom Eve, Andrew Rannells as William Clockwell, Zazie Beetz as Amber Bennett, Walton Goggins as Cecil Stedman, Jason Mantzoukas as Rex Sloan/Rex Splode, Mae Whitman as Fightmaster &amp; Dropkick, Chris Diamantopoulos as Donald Ferguson/Doc Seismic, Khary Payton as Black Samson, Zachary Quinto as Rudy Conners/Robot, Malese Jow as Kate Cha/Dupli-Kate, Kevin Michael Richardson as Mauler Twins &amp; Monster Girl, Grey Griffin as Shrinking Ray &amp; Amanda, Max Burkholder as Oliver Grayson, Lauren Cohan as War Woman, Sonequa Martin-Green as Green Ghost, Chad Coleman as Martian Man, Michael Cudlitz as Red Rush, Lennie James as Darkwing, Ross Marquand as The Immortal &amp; Aquarius, and Mahershala Ali as Titan.</p><p>Here&#8217;s the teaser trailer for the series, along with Prime Video&#8217;s description:</p><blockquote><p>INVINCIBLE is an adult animated superhero series that revolves around 17-year-old Mark Grayson (Steven Yeun), who’s just like every other guy his age — except his father is the most powerful superhero on the planet, Omni-Man (J.K. Simmons). But as Mark develops powers of his own, he discovers his father’s legacy may not be as heroic as it seems. From Robert Kirkman, the creator of The Walking Dead. Coming to Prime Video in 2021.</p></blockquote><p style="text-align: center;"><iframe src="https://www.youtube.com/embed/JuMiq7eg91M" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p><p>No release date has been given yet, although Amazon has confirmed that the series will come to air sometime in 2021.</p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" data-a2a-title="The First Teaser Trailer For Robert Kirkman’s ‘Invincible’ Has Arrived"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_skype" href="https://www.addtoany.com/add_to/skype?linkurl=https%3A%2F%2Fsciencefiction.com%2F2020%2F10%2F12%2Fthe-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived%2F&amp;linkname=The%20First%20Teaser%20Trailer%20For%20Robert%20Kirkman%E2%80%99s%20%E2%80%98Invincible%E2%80%99%20Has%20Arrived" title="Skype" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_like addtoany_special_service" data-layout="button" data-href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/"></a><a class="a2a_button_twitter_tweet addtoany_special_service" data-url="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" data-text="The First Teaser Trailer For Robert Kirkman’s ‘Invincible’ Has Arrived"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div></div><div class="post-tags"><span class="single-tag-list-title">Tags:</span><ul><li><a href="https://sciencefiction.com/tag/amazon/" rel="tag">Amazon</a></li><li><a href="https://sciencefiction.com/tag/cartoon/" rel="tag">Cartoon</a></li><li><a href="https://sciencefiction.com/tag/image-comics/" rel="tag">Image Comics</a></li><li><a href="https://sciencefiction.com/tag/invincible/" rel="tag">Invincible</a></li><li><a href="https://sciencefiction.com/tag/prime-video/" rel="tag">prime video</a></li><li><a href="https://sciencefiction.com/tag/robert-kirkman/" rel="tag">Robert Kirkman</a></li><li><a href="https://sciencefiction.com/tag/seth-rogen/" rel="tag">Seth Rogen</a></li><li><a href="https://sciencefiction.com/tag/the-walking-dead/" rel="tag">The Walking Dead</a></li><li><a href="https://sciencefiction.com/tag/tv-series/" rel="tag">tv series</a></li></ul></div><div class="post-author"><div class="author-image">
<img alt='' src='https://sciencefiction.com/wp-content/litespeed/avatar/17378c79df024a3dfbc72150956f6a2f.jpg' srcset='https://sciencefiction.com/wp-content/litespeed/avatar/b93bdca9d0e7a38a3e386e83ade83492.jpg 2x' class='avatar avatar-80 photo' height='80' width='80' /></div><div class="author-info"><h3 class="author-name">
Tony Schaab - Senior Editor</h3><p>Tony Schaab is a freelance pop-culture writer in addition to being an award-winning author and best-selling review critic, with his book series “The G.O.R.E. Score: A Review Guide to All Things Zombie” being an 8-time #1 best-seller (Amazon Kindle, Pop Culture chart, 2012-2017). Working as a DJ and Master of Ceremonies since 1999, he has performed MC/DJ work for the NFL, MTV, NBA, Wizard World Comic Con, PGA, IndyCar, and countless private events. Tony lives in Indianapolis with his wife, 10-year-old daughter, 2-year-old son, and two rambunctious rescue dogs. Learn more about Tony at TonySchaab.com and chat him up on Twitter @TonySchaab.</p><ul><li><a target="_blank" href="https://facebook.com/tonyschaab"><i class="fa fa-facebook"></i></a></li><li><a target="_blank" href="https://twitter.com/tonyschaab"><i class="fa fa-twitter"></i></a></li><li><a target="_blank" href="https://instagram.com/tonyschaab"><i class="fa fa-instagram"></i></a></li></ul></div></div><div style="clear:both;"></div><div style="margin: 20px auto; text-align: center;" id="zergnet-widget-32974"></div> <script src="data:text/javascript;base64, KGZ1bmN0aW9uKCl7dmFyIHplcmduZXQ9ZG9jdW1lbnQuY3JlYXRlRWxlbWVudCgnc2NyaXB0Jyk7emVyZ25ldC50eXBlPSd0ZXh0L2phdmFzY3JpcHQnO3plcmduZXQuYXN5bmM9dHJ1ZTt6ZXJnbmV0LnNyYz0naHR0cHM6Ly93d3cuemVyZ25ldC5jb20vemVyZy5qcz9pZD0zMjk3NCc7dmFyIHpuc2NyPWRvY3VtZW50LmdldEVsZW1lbnRzQnlUYWdOYW1lKCdzY3JpcHQnKVswXTt6bnNjci5wYXJlbnROb2RlLmluc2VydEJlZm9yZSh6ZXJnbmV0LHpuc2NyKTt9KSgpOw==" defer language="javascript" type="text/javascript"></script> <nav class="post-directions"><div class="row"><div class="col-md-6 col-sm-6 col-xs-12 previous-article">
<i class="fa fa-angle-left"></i><div class="post-directions-inwrap">
<span></span>
<a href="https://sciencefiction.com/2020/10/09/the-expanse-season-5-trailer-and-release-date-announced/">&#8216;The Expanse&#8217; Season 5 Trailer And Release Date Announced</a></div></div><div class="col-md-6 col-sm-6 col-xs-12 next-article"></div></div></nav><aside class="related-posts"><div class="related-posts-inwrap"><div class="row"><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-159157 post type-post status-publish format-standard hentry category-arrow category-comic-books category-tv-streaming tag-arrow tag-comic tag-the-cw" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2014/09/01/arrow-getting-season-2-5-expand-universe-comic-format/">
<img src="https://sciencefiction.com/wp-content/themes/broden/images/default-post-image.jpg" alt="&#8216;Arrow&#8217; Is Getting A Season 2.5 To Expand The Universe In Comic Format!" />
</a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2014/09/01/arrow-getting-season-2-5-expand-universe-comic-format/" title="&#8216;Arrow&#8217; Is Getting A Season 2.5 To Expand The Universe In Comic Format!">&#8216;Arrow&#8217; Is Getting A Season 2.5 To Expand The Universe In Comic Format!</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2014/09/01/arrow-getting-season-2-5-expand-universe-comic-format/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="159157 http://sciencefiction.com/?p=159157">Leave a comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> September 1, 2014</div></div></div></article><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-138911 post type-post status-publish format-standard hentry category-arrow category-comic-books category-dc-comics category-tv-streaming tag-barry-allen tag-candice-patton tag-danielle-panabaker tag-grant-gustin tag-iris-west tag-rick-cosnett tag-the-flash" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2014/02/06/flash-pilot-cast-candice-patton-iris-west/">
<img src="https://sciencefiction.com/wp-content/themes/broden/images/default-post-image.jpg" alt="&#8216;The Flash&#8217; Pilot Has Cast Candice Patton As Iris West" />
</a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2014/02/06/flash-pilot-cast-candice-patton-iris-west/" title="&#8216;The Flash&#8217; Pilot Has Cast Candice Patton As Iris West">&#8216;The Flash&#8217; Pilot Has Cast Candice Patton As Iris West</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2014/02/06/flash-pilot-cast-candice-patton-iris-west/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="138911 http://sciencefiction.com/?p=138911">1 Comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> February 6, 2014</div></div></div></article><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-315519 post type-post status-publish format-standard has-post-thumbnail hentry category-horror category-tv-streaming tag-amc tag-the-walking-dead" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2019/02/01/walking-dead-midseason-premiere-will-air-super-bowl-sunday/"><img width="750" height="422" src="https://sciencefiction.com/wp-content/uploads/2019/02/amc_the-walking-dead.jpg" class="attachment-broden-post-type-thumb size-broden-post-type-thumb wp-post-image" alt="" itemprop="image" srcset="https://sciencefiction.com/wp-content/uploads/2019/02/amc_the-walking-dead.jpg 750w, https://sciencefiction.com/wp-content/uploads/2019/02/amc_the-walking-dead-300x169.jpg 300w" sizes="(max-width: 750px) 100vw, 750px" /></a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2019/02/01/walking-dead-midseason-premiere-will-air-super-bowl-sunday/" title="&#8216;The Walking Dead&#8217; Midseason Premiere Will Air&#8230; On Super Bowl Sunday">&#8216;The Walking Dead&#8217; Midseason Premiere Will Air&#8230; On Super Bowl Sunday</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2019/02/01/walking-dead-midseason-premiere-will-air-super-bowl-sunday/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="315519 http://sciencefiction.com/?p=315519">Leave a comment</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> February 1, 2019</div></div></div></article><article class="col-md-6 col-sm-6 col-xs-12 grid-style post-hover post-119944 post type-post status-publish format-standard hentry category-comic-books category-dark-horse category-movies category-star-wars tag-disney tag-emperor-palpatine tag-ian-mcdiarmid tag-lucasfilm-ltd tag-star-wars" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a href="https://sciencefiction.com/2013/08/14/star-wars-episode-vii-rumor-alert-ian-mcdiarmid-to-return-as-emperor-palpatine/">
<img src="https://sciencefiction.com/wp-content/themes/broden/images/default-post-image.jpg" alt="&#8216;Star Wars: Episode VII&#8217; Rumor Alert &#8211; Ian McDiarmid To Return As Emperor Palpatine?" />
</a></figure><div class="post-inwrap"><h4 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2013/08/14/star-wars-episode-vii-rumor-alert-ian-mcdiarmid-to-return-as-emperor-palpatine/" title="&#8216;Star Wars: Episode VII&#8217; Rumor Alert &#8211; Ian McDiarmid To Return As Emperor Palpatine?">&#8216;Star Wars: Episode VII&#8217; Rumor Alert &#8211; Ian McDiarmid To Return As Emperor Palpatine?</a></h4><div class="post-meta"><div class="post-comment">
<i class="fa fa-comment-o"></i> <span class="comments-link"><a href="https://sciencefiction.com/2013/08/14/star-wars-episode-vii-rumor-alert-ian-mcdiarmid-to-return-as-emperor-palpatine/#disqus_thread"><span class="dsq-postid" data-dsqidentifier="119944 http://sciencefiction.com/?p=119944">7 Comments</span></a></span></div><div class="post-date"><i class="fa fa-clock-o"></i> August 14, 2013</div></div></div></article></div></div></aside><div id="disqus_thread"></div></div></article></div><div class="col-md-4 col-sm-12 col-xs-12 sidebar"><div class="sidebar-inwrap"><aside id="mc4wp_form_widget-4" class="widget widget_mc4wp_form_widget"><div class="widget-title"><h4>Newsletter Signup</h4></div><script src="data:text/javascript;base64, KGZ1bmN0aW9uKCl7d2luZG93Lm1jNHdwPXdpbmRvdy5tYzR3cHx8e2xpc3RlbmVyczpbXSxmb3Jtczp7b246ZnVuY3Rpb24oZXZ0LGNiKXt3aW5kb3cubWM0d3AubGlzdGVuZXJzLnB1c2goe2V2ZW50OmV2dCxjYWxsYmFjazpjYn0pO319fX0pKCk7" defer></script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-252323 mc4wp-form-theme mc4wp-form-theme-light" method="post" data-id="252323" data-name="Site Subscribe" ><div class="mc4wp-form-fields"><p>
<label>Email address: </label>
<input type="email" name="EMAIL" placeholder="Your email address" required /></p><p>
<input type="submit" value="Sign up" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1602531602" /><input type="hidden" name="_mc4wp_form_id" value="252323" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="zergnet-widget-32976"></div><div id="zergnet-widget-32984"></div></div></aside><aside id="broden_latest_posts_widget-4" class="widget latest-posts-widget"><div class="widget-title"><h4>Latest Articles</h4></div><div class="widget-inwrap"><ul><li class="post-355269 post type-post status-publish format-standard has-post-thumbnail hentry category-amazon-prime category-comic-books category-image-comics category-tv-streaming tag-amazon tag-cartoon tag-image-comics tag-invincible tag-prime-video tag-robert-kirkman tag-seth-rogen tag-the-walking-dead tag-tv-series" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-2-150x150.png" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" srcset="https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-2-150x150.png 150w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-2-650x650.png 650w, https://sciencefiction.com/wp-content/uploads/2020/10/Invincible-Screen-Capture-2-670x670.png 670w" sizes="(max-width: 150px) 100vw, 150px" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/" title="The First Teaser Trailer For Robert Kirkman&#8217;s &#8216;Invincible&#8217; Has Arrived" rel="bookmark">The First Teaser Trailer For Robert Kirkman&#8217;s &#8216;Invincible&#8217; Has Arrived</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2020/10/12/the-first-teaser-trailer-for-robert-kirkmans-invincible-has-arrived/"><i class="fa fa-clock-o"></i> October 12, 2020</a></div></div></div></li><li class="post-355264 post type-post status-publish format-standard has-post-thumbnail hentry category-amazon-prime category-tv-streaming tag-fifth-season tag-premiere tag-release-date tag-the-expanse tag-trailer" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2020/10/09/the-expanse-season-5-trailer-and-release-date-announced/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2019/12/Amazon_The_Expanse_Main-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="Amazon_The_Expanse_Main" itemprop="image" srcset="https://sciencefiction.com/wp-content/uploads/2019/12/Amazon_The_Expanse_Main-150x150.jpg 150w, https://sciencefiction.com/wp-content/uploads/2019/12/Amazon_The_Expanse_Main-650x650.jpg 650w, https://sciencefiction.com/wp-content/uploads/2019/12/Amazon_The_Expanse_Main-670x670.jpg 670w" sizes="(max-width: 150px) 100vw, 150px" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2020/10/09/the-expanse-season-5-trailer-and-release-date-announced/" title="&#8216;The Expanse&#8217; Season 5 Trailer And Release Date Announced" rel="bookmark">&#8216;The Expanse&#8217; Season 5 Trailer And Release Date Announced</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2020/10/09/the-expanse-season-5-trailer-and-release-date-announced/"><i class="fa fa-clock-o"></i> October 9, 2020</a></div></div></div></li><li class="post-355261 post type-post status-publish format-standard has-post-thumbnail hentry category-avengers category-comic-books category-disney category-kevin-feige category-marvel category-movies category-sony category-spider-man tag-benedict-cumberbatch tag-doctor-strange tag-electro tag-jamie-foxx tag-marvel-cinematic-universe tag-mcu tag-spider-man-3 tag-tom-holland" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2020/10/08/benedict-cumberbatch-is-officially-bringing-doctor-strange-to-spider-man-3/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2020/10/Doctor-Strange-SpiderMan-Avengers-Infinity-War-150x150.jpeg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2020/10/08/benedict-cumberbatch-is-officially-bringing-doctor-strange-to-spider-man-3/" title="Benedict Cumberbatch Is Officially Bringing Doctor Strange To &#8216;Spider-Man 3&#8217;" rel="bookmark">Benedict Cumberbatch Is Officially Bringing Doctor Strange To &#8216;Spider-Man 3&#8217;</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2020/10/08/benedict-cumberbatch-is-officially-bringing-doctor-strange-to-spider-man-3/"><i class="fa fa-clock-o"></i> October 8, 2020</a></div></div></div></li><li class="post-355257 post type-post status-publish format-standard has-post-thumbnail hentry category-book-review category-books category-star-wars category-throwback tag-book tag-death-troopers tag-legends tag-novel tag-recap tag-retro-review tag-review tag-star-wars tag-throwback-thursday" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2020/10/08/book-review-star-wars-death-troopers-2007/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2020/10/Star-Wars-Death-Troopers-Featured-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" srcset="https://sciencefiction.com/wp-content/uploads/2020/10/Star-Wars-Death-Troopers-Featured-150x150.jpg 150w, https://sciencefiction.com/wp-content/uploads/2020/10/Star-Wars-Death-Troopers-Featured-650x650.jpg 650w, https://sciencefiction.com/wp-content/uploads/2020/10/Star-Wars-Death-Troopers-Featured-670x670.jpg 670w" sizes="(max-width: 150px) 100vw, 150px" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2020/10/08/book-review-star-wars-death-troopers-2007/" title="Book Review: &#8216;Star Wars: Death Troopers&#8217; (2007)" rel="bookmark">Book Review: &#8216;Star Wars: Death Troopers&#8217; (2007)</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2020/10/08/book-review-star-wars-death-troopers-2007/"><i class="fa fa-clock-o"></i> October 8, 2020</a></div></div></div></li></ul></div></aside><aside id="broden_popular_posts_widget-4" class="widget most-popular-widget"><div class="widget-title"><h4>Most Popular Articles</h4></div><div class="widget-inwrap"><ul><li class="post-257878 post type-post status-publish format-standard has-post-thumbnail hentry category-comic-books category-marvel category-tv-streaming tag-the-defenders tag-tv-review" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2017/08/23/tv-defenders-review-episodes-3-4/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2017/08/DEFENDERS-ready-for-action-HEADER-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2017/08/23/tv-defenders-review-episodes-3-4/" title="TV REVIEW: ‘The Defenders’ – Episodes 3 &#038; 4" rel="bookmark">TV REVIEW: ‘The Defenders’ – Episodes 3 &#038; 4</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2017/08/23/tv-defenders-review-episodes-3-4/"><i class="fa fa-clock-o"></i> August 23, 2017</a></div></div></div></li><li class="post-52559 post type-post status-publish format-standard has-post-thumbnail hentry category-comic-books category-featured category-other" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2012/03/17/top-10-green-super-heroes/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2012/03/Green-Lantern-1024x575-640x359-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2012/03/17/top-10-green-super-heroes/" title="Top 10 Green Superheroes" rel="bookmark">Top 10 Green Superheroes</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2012/03/17/top-10-green-super-heroes/"><i class="fa fa-clock-o"></i> March 17, 2012</a></div></div></div></li><li class="post-277016 post type-post status-publish format-standard has-post-thumbnail hentry category-movies category-science-and-tech tag-jurassic-world-3" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2018/02/22/circle-life-jurassic-world-3-eyeing-2021-release-date-complete-trilogy/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2018/02/jurassic-world-blu-ray-t-rex-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2018/02/22/circle-life-jurassic-world-3-eyeing-2021-release-date-complete-trilogy/" title="Circle Of Life: &#8216;Jurassic World 3&#8217; Eyeing 2021 Release Date To Complete Trilogy" rel="bookmark">Circle Of Life: &#8216;Jurassic World 3&#8217; Eyeing 2021 Release Date To Complete Trilogy</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2018/02/22/circle-life-jurassic-world-3-eyeing-2021-release-date-complete-trilogy/"><i class="fa fa-clock-o"></i> February 22, 2018</a></div></div></div></li><li class="post-350453 post type-post status-publish format-standard has-post-thumbnail hentry category-events category-featured category-movies tag-amblin-entertainment tag-richard-donner tag-steven-spielberg tag-the-goonies tag-warner-brothers" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2020/02/10/oregon-is-hosting-a-four-day-event-to-celebrate-the-35th-anniversary-of-the-goonies/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" srcset="https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-150x150.jpg 150w, https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-200x200.jpg 200w, https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-750x750.jpg 750w, https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-768x768.jpg 768w, https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-650x650.jpg 650w, https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1-670x670.jpg 670w, https://sciencefiction.com/wp-content/uploads/2020/02/Goonies-Sean-Astin-1.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2020/02/10/oregon-is-hosting-a-four-day-event-to-celebrate-the-35th-anniversary-of-the-goonies/" title="Oregon Is Hosting A Four-Day Event To Celebrate The 35th Anniversary Of &#8216;The Goonies&#8217;" rel="bookmark">Oregon Is Hosting A Four-Day Event To Celebrate The 35th Anniversary Of &#8216;The Goonies&#8217;</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2020/02/10/oregon-is-hosting-a-four-day-event-to-celebrate-the-35th-anniversary-of-the-goonies/"><i class="fa fa-clock-o"></i> February 10, 2020</a></div></div></div></li><li class="post-105228 post type-post status-publish format-standard has-post-thumbnail hentry category-comic-books category-dc-comics category-image-comics category-marvel tag-dc-comics tag-lbgt tag-marvel tag-transgender" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2013/04/15/top-ten-transgender-comic-book-characters/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2013/04/alysia-yeoh-batgirl-150x150.png" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="" itemprop="image" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2013/04/15/top-ten-transgender-comic-book-characters/" title="Top Ten Transgender Comic Book Characters" rel="bookmark">Top Ten Transgender Comic Book Characters</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2013/04/15/top-ten-transgender-comic-book-characters/"><i class="fa fa-clock-o"></i> April 15, 2013</a></div></div></div></li><li class="post-308647 post type-post status-publish format-standard has-post-thumbnail hentry category-books category-featured category-movies category-tv-streaming tag-kingkiller-chronicle tag-lin-manuel-miranda tag-lionsgate tag-patrick-rothfuss tag-sam-raimi tag-showtime" itemscope="itemscope" itemtype="http://schema.org/Article"><figure class="post-image">
<a class="post-thumbnail" href="https://sciencefiction.com/2018/12/01/raimi-kingkiller-chronicle/">
<img width="150" height="150" src="https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-150x150.jpg" class="attachment-broden-grid-small size-broden-grid-small wp-post-image" alt="Sam Raimi" itemprop="image" srcset="https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-150x150.jpg 150w, https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-300x300.jpg 300w, https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-768x768.jpg 768w, https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-650x650.jpg 650w, https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169-670x670.jpg 670w, https://sciencefiction.com/wp-content/uploads/2018/12/shutterstock_128776169.jpg 1000w" sizes="(max-width: 150px) 100vw, 150px" />								</a></figure><div class="post-inwrap"><div class="post-title"><h2 itemprop="name" class="entry-title"><a itemprop="url" href="https://sciencefiction.com/2018/12/01/raimi-kingkiller-chronicle/" title="EXCLUSIVE: Sam Raimi No Longer Attached To Direct &#8216;Kingkiller Chronicle&#8217; Movie" rel="bookmark">EXCLUSIVE: Sam Raimi No Longer Attached To Direct &#8216;Kingkiller Chronicle&#8217; Movie</a></h2></div><div class="post-meta"><div class="post-date"><a href="https://sciencefiction.com/2018/12/01/raimi-kingkiller-chronicle/"><i class="fa fa-clock-o"></i> December 1, 2018</a></div></div></div></li></ul></div></aside></div></div></div></div></section></section><footer><div class="copyright"><p><span class="copy1"> Copyright &copy;2020 Science Fiction.</span>
<span class="copy-2">All Rights Reserved</span> | <a href="https://sciencefiction.com/privacy-policy">Privacy Policy</a> | <a href="https://sciencefiction.com/do-not-sell-my-information">Do Not Sell My Information</a><br /><br />
<span>Website Design&nbsp;and <a href="https://quichost.com/" alt="HTTP3/QUIC Hosting" target="_blank" rel="noopener">HTTP3/QUIC Hosting</a> by <a href="https://quichost.com/" alt="HTTP3/QUIC Hosting" target="_blank" rel="noopener">QUICHOST.COM</a></span></p></div><div class="back-to-top"><a href="#"><i class="fa fa-angle-double-up"></i></a></div></footer></div></div> <script src="data:text/javascript;base64, dmFyIF91c2Vyd2F5X2NvbmZpZz17YWNjb3VudDonQzBvSHdNcGRjSyd9Ow==" defer type="text/javascript"></script> <script src="data:text/javascript;base64, KGZ1bmN0aW9uKCl7ZnVuY3Rpb24gbWF5YmVQcmVmaXhVcmxGaWVsZCgpe2lmKHRoaXMudmFsdWUudHJpbSgpIT09JycmJnRoaXMudmFsdWUuaW5kZXhPZignaHR0cCcpIT09MCl7dGhpcy52YWx1ZT0iaHR0cDovLyIrdGhpcy52YWx1ZTt9fQp2YXIgdXJsRmllbGRzPWRvY3VtZW50LnF1ZXJ5U2VsZWN0b3JBbGwoJy5tYzR3cC1mb3JtIGlucHV0W3R5cGU9InVybCJdJyk7aWYodXJsRmllbGRzKXtmb3IodmFyIGo9MDtqPHVybEZpZWxkcy5sZW5ndGg7aisrKXt1cmxGaWVsZHNbal0uYWRkRXZlbnRMaXN0ZW5lcignYmx1cicsbWF5YmVQcmVmaXhVcmxGaWVsZCk7fX19KSgpOw==" defer></script> <script src="data:text/javascript;base64, dmFyIGNvdW50VmFycz17ImRpc3F1c1Nob3J0bmFtZSI6InNjaWVuY2VmaWN0aW9uY29tIn07dmFyIGVtYmVkVmFycz17ImRpc3F1c0NvbmZpZyI6eyJpbnRlZ3JhdGlvbiI6IndvcmRwcmVzcyAzLjAuMTYifSwiZGlzcXVzSWRlbnRpZmllciI6IjM1NTI2OSBodHRwczpcL1wvc2NpZW5jZWZpY3Rpb24uY29tXC8/cD0zNTUyNjkiLCJkaXNxdXNTaG9ydG5hbWUiOiJzY2llbmNlZmljdGlvbmNvbSIsImRpc3F1c1RpdGxlIjoiVGhlIEZpcnN0IFRlYXNlciBUcmFpbGVyIEZvciBSb2JlcnQgS2lya21hblx1MjAxOXMgXHUyMDE4SW52aW5jaWJsZVx1MjAxOSBIYXMgQXJyaXZlZCIsImRpc3F1c1VybCI6Imh0dHBzOlwvXC9zY2llbmNlZmljdGlvbi5jb21cLzIwMjBcLzEwXC8xMlwvdGhlLWZpcnN0LXRlYXNlci10cmFpbGVyLWZvci1yb2JlcnQta2lya21hbnMtaW52aW5jaWJsZS1oYXMtYXJyaXZlZFwvIiwicG9zdElkIjoiMzU1MjY5In07dmFyIGRjbEN1c3RvbVZhcnM9eyJkY2xfcHJvZ3Jlc3NfdGV4dCI6IkxvYWRpbmcuLi4ifTs=" defer type='text/javascript'></script> <script src="data:text/javascript;base64, dmFyIHRoZW1lYWpheD17ImFqYXh1cmwiOiJodHRwczpcL1wvc2NpZW5jZWZpY3Rpb24uY29tXC93cC1hZG1pblwvYWRtaW4tYWpheC5waHAifTs=" defer type='text/javascript'></script> <script src="data:text/javascript;base64, Y29uc3QgbG9hZFNjcmlwdHNUaW1lcj1zZXRUaW1lb3V0KGxvYWRTY3JpcHRzLDcqMTAwMCk7Y29uc3QgdXNlckludGVyYWN0aW9uRXZlbnRzPVsibW91c2VvdmVyIiwia2V5ZG93biIsInRvdWNobW92ZSIsInRvdWNoc3RhcnQiXTt1c2VySW50ZXJhY3Rpb25FdmVudHMuZm9yRWFjaChmdW5jdGlvbihldmVudCl7d2luZG93LmFkZEV2ZW50TGlzdGVuZXIoZXZlbnQsdHJpZ2dlclNjcmlwdExvYWRlcix7cGFzc2l2ZTohMH0pfSk7ZnVuY3Rpb24gdHJpZ2dlclNjcmlwdExvYWRlcigpe2xvYWRTY3JpcHRzKCk7Y2xlYXJUaW1lb3V0KGxvYWRTY3JpcHRzVGltZXIpO3VzZXJJbnRlcmFjdGlvbkV2ZW50cy5mb3JFYWNoKGZ1bmN0aW9uKGV2ZW50KXt3aW5kb3cucmVtb3ZlRXZlbnRMaXN0ZW5lcihldmVudCx0cmlnZ2VyU2NyaXB0TG9hZGVyLHtwYXNzaXZlOiEwfSl9KX0KZnVuY3Rpb24gbG9hZFNjcmlwdHMoKXtkb2N1bWVudC5xdWVyeVNlbGVjdG9yQWxsKCJzY3JpcHRbZGF0YS10eXBlPSdsYXp5J10iKS5mb3JFYWNoKGZ1bmN0aW9uKGVsZW0pe2VsZW0uc2V0QXR0cmlidXRlKCJzcmMiLGVsZW0uZ2V0QXR0cmlidXRlKCJkYXRhLXNyYyIpKX0pfQ==" defer type="text/javascript" id="flying-scripts"></script> <script src="data:text/javascript;base64, ZnVuY3Rpb24gemVyZ29ubG9hZDEoKXt2YXIgemVyZ25ldD1kb2N1bWVudC5jcmVhdGVFbGVtZW50KCdzY3JpcHQnKTt6ZXJnbmV0LnNyYz0naHR0cHM6Ly93d3cuemVyZ25ldC5jb20vemVyZy5qcz9pZD0zMjk3Nic7dmFyIHpuc2NyPWRvY3VtZW50LmdldEVsZW1lbnRzQnlUYWdOYW1lKCdzY3JpcHQnKVswXTt6bnNjci5wYXJlbnROb2RlLmluc2VydEJlZm9yZSh6ZXJnbmV0LHpuc2NyKTtkb2N1bWVudC5ib2R5LmFwcGVuZENoaWxkKGVsZW1lbnQpO30KaWYod2luZG93LmFkZEV2ZW50TGlzdGVuZXIpCndpbmRvdy5hZGRFdmVudExpc3RlbmVyKCJsb2FkIix6ZXJnb25sb2FkMSxmYWxzZSk7ZWxzZSBpZih3aW5kb3cuYXR0YWNoRXZlbnQpCndpbmRvdy5hdHRhY2hFdmVudCgib25sb2FkIix6ZXJnb25sb2FkMSk7ZWxzZSB3aW5kb3cub25sb2FkPXplcmdvbmxvYWQxOw==" defer language="javascript" type="text/javascript"></script> <script src="data:text/javascript;base64, ZnVuY3Rpb24gemVyZ29ubG9hZDIoKXt2YXIgemVyZ25ldD1kb2N1bWVudC5jcmVhdGVFbGVtZW50KCdzY3JpcHQnKTt6ZXJnbmV0LnNyYz0naHR0cHM6Ly93d3cuemVyZ25ldC5jb20vemVyZy5qcz9pZD0zMjk4NCc7dmFyIHpuc2NyPWRvY3VtZW50LmdldEVsZW1lbnRzQnlUYWdOYW1lKCdzY3JpcHQnKVswXTt6bnNjci5wYXJlbnROb2RlLmluc2VydEJlZm9yZSh6ZXJnbmV0LHpuc2NyKTtkb2N1bWVudC5ib2R5LmFwcGVuZENoaWxkKGVsZW1lbnQpO30KaWYod2luZG93LmFkZEV2ZW50TGlzdGVuZXIpCndpbmRvdy5hZGRFdmVudExpc3RlbmVyKCJsb2FkIix6ZXJnb25sb2FkMixmYWxzZSk7ZWxzZSBpZih3aW5kb3cuYXR0YWNoRXZlbnQpCndpbmRvdy5hdHRhY2hFdmVudCgib25sb2FkIix6ZXJnb25sb2FkMik7ZWxzZSB3aW5kb3cub25sb2FkPXplcmdvbmxvYWQyOw==" defer language="javascript" type="text/javascript"></script> <script type="text/javascript" defer data-deferred="1" data-type="lazy" data-src="https://cdn.userway.org/widget.js"></script><script data-optimized="1" src="https://sciencefiction.com/wp-content/litespeed/cssjs/5aa1a.js?32f3e" defer></script></body></html>
<!-- Page optimized by LiteSpeed Cache @2020-10-12 19:40:03 -->
<!-- Page generated by LiteSpeed Cache 3.4.2 on 2020-10-12 15:40:03 -->